Fusebill Staging Environment Access & Phone
Incident Report for Fusebill Staging
Resolved
This incident has been resolved.
Posted Jul 28, 2022 - 11:49 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 08, 2022 - 10:54 EDT
Update
We are continuing to investigate this issue.
Posted Jul 08, 2022 - 10:54 EDT
Investigating
Rogers Canada is currently experiencing an national outage. As a result, the Fusebill staging environment, and phone system is currently down.

Our production environment and support email are still online.

The best way to reach support is support@fusebill.com

We appreciate your patience, understanding, and cooperation
Posted Jul 08, 2022 - 10:54 EDT